Ability Photopaint............................................................................................................................ 51
   Photopaint Tutorials .................................................................................................................. 51
   Tutorial 1 – Opening an image .............................................................................................. 51
   Tutorial 2 – Selections ........................................................................................................... 52
   Tutorial 3 – Applying brushstrokes ...................................................................................... 53
   Tutorial 4 – Fill ..................................................................................................................... 55
   Tutorial 5 – Filters ................................................................................................................ 55
   Tutorial 6 – Layers ............................................................................................................... 56

Integration within Ability Office................................................................................................. 59
Introducing Ability Office

Write, Spreadsheet, Database, Photopaint

Thank you for choosing Ability Office. This professional office suite consists of four powerful applications:

- WRITE lets you create, format and print documents.
- SPREADSHEET lets you create numeric models, make “what if” projections, produce cash flows, and draw charts.
- DATABASE lets you organize and store information, create reports, and use on-screen forms.
- PHOTOPAINT lets you edit photographs and design images.

Ability Office also contains two mini-applications – LAUNCHER provides a tool for starting all the Ability applications and opening Ability files and DRAW lets you create vector object based drawings.

How to use this booklet

This booklet presents some of the basic concepts and features of Ability and shows you how to use them. It is intended to give you clear guidelines to some of the fundamental ways in which Ability Office can help you get your work done. There is often more than one method for performing a particular action, but here only the simplest method is used.

For more detailed information each application has built-in automated Help files that explain specific features in greater depth.

Windows Basics for the Beginner

Many basic features of Write will be familiar to anyone who has used other Windows applications. If you’re new to computing the following is an explanation of some of these fundamentals:

Clicking

If your mouse button has more than one button, use the left button unless otherwise advised. To click on an item (such as a button or a window), move the mouse until the mouse pointer is resting on the item on-screen. Then push down and release the mouse button.

To double-click on an item, position the mouse pointer and then click and release the mouse button rapidly, twice in succession.

Selecting

You will constantly be selecting text and other items, for instance, when you select text for formatting. Follow this procedure:

1. Use the mouse to point to the start of the area you want to select.
2. Holding down the mouse button, move the mouse pointer to the end point of the area you want to select.
3. Release the mouse button.

The area should now be selected (visible by inverse color on screen).
Using menus

Ability has a series of pull-down menus from which you can select commands. The titles of these menus (File, Edit, etc.) appear along the menu bar at the top of the window.

To open a menu, click on the required menu title; to choose a command from the menu, move the mouse pointer to the command and click again. The menu will close and Ability will perform the chosen action (or sometimes open up a dialog box for you to select further commands).

Note: Not all menu commands are available at all times. For instance, if no document is open, the Save command will not be available, and appears “grayed out” in the File menu.

Shortcut menus

Shortcut menus are special menus that are tailored to match the application you are currently working in. They are accessed by right-clicking (pressing the right mouse button) over a part of the working document; the shortcut menu will pop up displaying a list of relevant commands. Many of the shortcut commands are also available through the normal menu bar at the top.

Shortcut keystrokes

Ability includes a number of shortcut keystrokes. These can save you time by letting you execute commands without opening the menus. They appear in the pull down menus next to the name of the command.

Installation

Hardware and software requirements

To run Ability, you need a minimum configuration of:

- A Personal Computer with a processor running at 200MHz or better.
- 16MB RAM. For Windows XP and later, 64MB is recommended.
- A hard disk with at least 30 MB of free space.
- A Microsoft Windows compatible mouse (optional)
- Ability works with the Microsoft Windows operating systems. This includes Windows 95/98/ME and Windows NT 4.0/2000/XP and later.

Installation – CD/DVD

1. Put the Ability CD into the CD or DVD drive.

2. The Ability installation program will start automatically (if not, select Start and then Run and enter D:SETUP where D: is your CD or DVD drive).

Installation – from download file

Ability can be downloaded and installed from the Ability web site. Follow the instructions in the download section at http://www.ability.com.
### Starting and ending an Ability session

#### Starting an application

To start any of the Ability applications, follow these steps:

1. Click the **Start** button on the Windows Taskbar
2. Select **Programs**
3. Select **Ability Office**
4. Select the application name

The application will then open ready for use. Alternatively, select the Ability Launcher from the list of Ability applications under Programs, and then click on the application button:

- Write
- Spreadsheet
- Photopaint
- Database
- Draw

#### Switching between Ability applications

If you already have one of the applications open, you can open or switch to any other application simply by clicking on its button on the launcher toolbar (If you can't see this toolbar, select the **Toolbars** option from the **View** menu and then check the **Launch** option.).

#### Exiting an application

To exit an application, select the **Exit** command from the **File** menu. If you have made changes to any open document since you last saved, you will be asked if you want to save them first.

Alternatively, click on the close box in the top right-hand corner of the application window.

#### Getting help

Each of the Ability applications, has a comprehensive Help facility.

##### Context sensitive help

- Select the "What's This?" help button and point and click on any toolbar button, menu command, or any other part of the application window, to view specific help on that item. In Dialog windows you can use the dialog "What's This?" button some dialogs also contain a Help button to provide supplementary assistance.

Also, note that **tooltips** are always available for toolbar buttons - just place the mouse pointer over a button and a brief description will pop up.
General help — the on-line help system

- Select the application help command e.g. Write Help from the Help menu to access the on-line help for that application.

- Select the User's Guide command from the Help menu to get the full on-line manual, which covers all the Ability applications plus basic file management tasks, such as how to organize documents and folders.

Using the on-line help

The Help Topics window provides you with three different ways of browsing the on-line help information. Click on one of the three tabs (from left to right):

- **Contents** - this is like the contents page of a book and is arranged in chapters, sub-chapters and, finally, help pages. Double-click on any chapter to see what's in it, and double-click on a help page to display the actual help.

- **Index** - allows you to search for key words. For example, enter "Mail Merge" (without the quotes) to locate all the help pages containing this key word.

- **Find** - searches for the supplied word in all the text within Help. When you first use this option, Windows will index the help system - this will take a short while.

Navigating inside the help pages

In the help pages, you can navigate through the rest of the help system as follows:

- Click on the green underlined links to move to related help topics.

- Use the Help Topics button to move back to the Help Topics Page.

- Use the forward and backward buttons to move to the next and previous topics respectively.

- Use the Back button to jump to the last visited topic.
Ability Write

Write is Ability Office’s word-processing application. With Write you can type a document, format it for features such as italics, font size and color, and then revise it till it matches what you’re after. Using Write, you can create and edit documents, letters, business reports, and other materials meant for print.

Write Tutorials

The following tutorials have been designed to equip you with the basics of how to use Write successfully.

Note, there is often more than one method for performing a particular action, but in this booklet only the simplest method has been included.

Tutorial 1 — Getting to Know the Write Window

The following section briefly covers the parts of the Write window that it is essential for you to understand.

The toolbars

Across the top of the window are the toolbars. The toolbars contain buttons and drop-down lists that enable you to format and manipulate the text quickly and easily. The two main toolbars in Write:

The Standard toolbar contains basic file opening, closing, saving, printing, editing, searching and zoom functions:

The format toolbar contains text styling options for fonts and paragraphs:

The horizontal ruler

Across the top of the window is the horizontal ruler. It shows the current margin settings and tab stops.
The vertical ruler

Down the left side of the Write screen is the vertical ruler. This is used to change the size of the top and bottom margins.

The status bar

At the bottom of the Write window is the status bar, which indicates the position of the cursor within the document, as well as providing other useful information.

Tutorial 2 — Entering text in a document

Start Write as described in the above section on Starting and Ending a Write Session. Write will open with a blank unsaved document – let's use this to explore the basic features.

The workspace and the cursor

The area in which you work on a Write document is called the workspace. You can think of this as a piece of paper that is ready to write on. If you click anywhere in the workspace a flashing vertical line will appear in the upper left area of the page: this is the cursor. Once you start typing, the letters appear to the left of the cursor location and the cursor moves to the right.

You do not need to press the Enter key at the end of a line of typing: Write automatically wraps the text round onto the next line when there is no more room on the current line. If, however, you want to start a new line of text, press Enter to force the cursor to jump to the start of the next line.

If you make a mistake you can use the ← (backspace) key to erase the offending letters one at a time.

Moving around a document

To move the cursor around a Write document, place the mouse pointer at the position required in the document and click. You can also move the cursor one character at a time using the arrow keys on your keyboard.

To view parts of the document not visible on screen, use the scroll bars at the right and bottom of the window: position the pointer over the slider and then click and hold down the mouse button to drag the slider in the required direction.
Closing a document

Look at the top right-hand corner of the screen, where there are two Close buttons. Clicking on the top one will close down Write; clicking on the one beneath that will close down the current document. Do the latter. A dialog window will open asking you if you wish to save the document. Since we’ve just been warming up so far, click on No.

Creating a new document

This time we’re going to create a document from scratch. Click on the New button on the toolbar to open a new document. The cursor should already be flashing at the top left of the document (if not, click once in the workspace). Type your letter, remembering to press the Enter key whenever you wish to force the cursor to start a new line (such as after the “Dear Sir” part). Don’t forget to include the address at the top and space to add your signature once the letter is printed.

Saving a document

Click on the Save button and the “Save as” dialog window will be displayed. Enter a name in the File name box and then click Save. Your letter will be saved under this name in the currently selected folder (the “My Documents” folder is the default current folder).

Note: It is recommended that you save your work often (to minimize what you lose in the event of a power cut or system crash). Simply click on the Save button at any time.

Moving text

Select the text you wish to move, then click on the Cut button on the toolbar. The text is removed from the document and placed in the clipboard, which can be thought of as your computer’s scratchpad.

To put the text back into another part of the document (or into another document), click where you want the removed text to go and then click on the Paste button on the toolbar. The text will be inserted at the cursor.

Note: The cut text stays in the clipboard until you put something else in there, so you can paste it into documents as many times as you like.

You can also use Drag and Drop to move text: Select the text and then depress and hold down the left mouse button. A square will appear beneath the mouse pointer. Keeping the mouse depressed, you can drag the square to a new location in the document. When you release the mouse the selected text will move to the new location.
Copying text

Select the text you wish to copy and then click on the Copy button on the toolbar. The text stays where it is but a copy is placed in the clipboard and can be pasted as above.

Deleting text

To remove text, first select it and then do one of the following:

- press the Del key
- press the ← (backspace) key
- simply overtype with something else

Replacing Text Automatically

You can use Write to find a word or phrase anywhere in a document. You can even change all occurrences of a particular word or phrase in a single “search and replace” operation. For example, if you have written a report on a company called Jeans Limited, and realize later that it is called Genes Limited, you can quickly search for every occurrence of Jeans and replace it with Genes.

Replacing text

To find and replace text, follow these steps:

1. Click on the Replace button on the toolbar to display the “Replace” dialog.
2. In the Find What box, type the text you wish to find.
3. In the Replace With box, type the text or phrase you wish to replace the found text with.
4. Click on the Replace button to find the next occurrence of the find text.
5. Now click on the Replace button again to perform the replacement or the Find Next button to skip that occurrence. Write then moves on to the next occurrence.

Alternatively, if you’re sure you wish to replace every instance of the find text without exception, you should click on the Replace All button.

Note: If you only wish to find a certain word or phrase (without replacing it) you can click on the Find button.

Rectifying mistakes

If you change your mind after making any changes to your document, you should click on the Undo button. Note that you can undo as many actions as you like e.g. you can retrace your steps, undoing each of your actions in order. Similarly, if you change your mind again, you can reverse the undo by clicking the Redo button.
Tutorial 5 — Tidying up your letter

Formatting text

Scroll to the top of the letter, position the mouse pointer just to the left of the first line of the address, and then press and hold the mouse button. Now move the pointer to the right of the last line of the address and release the mouse button. The address should now be highlighted in inverse colors (white on black) to show you it has been selected. Now click on the Right Align button and the address will move across to the right of your page. You've now performed your first piece of formatting. See Appendix A for a list of commonly used formatting functions.

Checking the spelling

Before printing any document it's a good idea to use Write's built-in spell checker. Click on the Spell button to begin. When the spell-checker comes across a word it does not recognize, the “Spelling” dialog is displayed.

The unrecognized word is shown in the Suggestion for box, and the reason for the query (e.g. word not found, or word doubled) is given next to it. The closest replacement (if any can be found) is given in the Change To box. To accept this suggestion, click on the Change button.

To see other suggestions, click on the Suggest button (which will be grayed out if there are no other suggestions). To choose one of these other suggestions, click on it and then on the Change button.

There are several other buttons you can use:

- Add - adds the highlighted word to your personal dictionary - (for more details select Write help from the Help menu and type “user defined dictionary” into the index).
- Ignore - ignores the highlighted word. Use this if the word is not misspelled but you do not wish to add it to the dictionary (for instance if it's a person's name or post code)

Using the thesaurus

For most of the words in your Write document, you can select, from a list of words, another one which has a similar meaning but is perhaps more appropriate in the context. These words are called synonyms.

To use the thesaurus, select the word whose synonym you wish to find, and then select the Thesaurus command from the Tools menu. The “Thesaurus” dialog window is displayed.

In the Looked Up box is the word you originally selected. Its broad meaning is given beneath in the Meanings box; of course, a word might have several meanings, in which case they will all be listed here. (Note, if the word you have looked up is not in the thesaurus, the title of the Looked Up box is changed to Not Found).

Contained in the Replace With Synonym box is the synonym that Write has chosen as being closest in meaning to the original word. Any further synonyms are listed beneath in the Synonyms box. Click on one of these synonyms to place it in the Replace With box. Double-click on a synonym to place it in the Looked Up box (you can then click on the Look Up button to display its synonyms).

When you have put the synonym you require into the Replace With Synonym box, click on the Replace button.
Tutorial 6 — Printing your letter

If you have a printer you can print a copy of your letter onto paper by clicking on the Print button on the toolbar.

Print Preview

Before printing you might like to see how your document is going to look on paper. To do this, click on the Preview button on the toolbar. The display switches to print preview mode, in which the document is shown at a reduced size, to give you an overall view. If you are happy with the layout, press the Print button; if you wish to make some more changes first, click on the Close button.

Note: If your letter goes over more than a single page you may find that a paragraph is split between two pages. If you don’t want the paragraph to be split, click on the start of the paragraph and select Page Break from the Insert menu. The paragraph is kept intact at the top of the second page.

Printing

Once you’ve clicked on the Print button the “Print” dialog window appears. Click on the OK button and the printing process will commence. There will be a pause while the information is sent to the printer, and then the physical printing will begin. For more information on printing select Write help from the Help menu and type “Printing” into the index.

If you have any trouble printing, see your printer documentation, or Windows help, for more details.

Tutorial 7 — Some More Advanced Features

We’ll now look at some more advanced features in Write.

Opening an existing document

To open an existing document, say the letter you created earlier, do the following:

1. Click the Open button on the toolbar. The “Open” dialog window will appear with a list of all the documents in the current folder (the “My Documents” folder is usually the default current folder).

2. To open a document located in another folder, use the Up One Level button and the Look in box to find the appropriate folder. Double-click on the folder icon.

3. Once you have located the document, click on the appropriate document icon to open the document i.e. the one linked to the name of the document followed by .aww

Saving a document under a different name

We’re going to make some changes to this document, but before we do that we’re going to save it under a different name and place it in a new folder. It is often a good idea to keep the original copy of a document and use save as to create a new document for you to edit.

1. Select the Save As command from the File menu.
2. Click on the **Up One Level** button several times to view all the folders and documents on your computer's hard drive (C:). Double-click on the “My Documents” folder icon to make that the current folder.

3. We could save the document here but, since it’s a good idea to get into the habit of organizing your documents, we’re going to create a new folder within the “My Documents” folder instead.
   
   Click on the **Create New Folder** button and then type in the name for the new folder. Call it “Letters”, say, and then press the Enter key. Double-click on this new folder.

4. Enter a new name in the **File name** box, call it “New Letter”, say, and then click **Save**. The new document is now saved in a the new folder.

### Tutorial 8 — Using styles

A style is a collection of attributes that you can apply to the different parts of your text, for example, font, font size and paragraph settings.

Click anywhere in the document and then look at the style box on the left of the Format toolbar - it should say “Normal”. Now select “Heading 1” from the style box, and after that “Heading 2”. As you can see there is a variety of styles for you to choose from, some with indents. Change the style back to “Normal”.

The general idea is to implement different formats in your text: headings can all be formatted with a “Heading 1” style, sub-headings can be formatted with a “Heading 2” style, and the general text can be left as the default “Normal” style.

To apply a style:

1. Select the text

2. Click on the arrow on the right of the Styles drop-down box.

3. Then select the style name from the style drop down list on the toolbar.

Note that the style is applied to a whole paragraph, or to all the paragraphs within a selected area.

For more details, select Write help from the Help menu and type “Styles” into the index.

### Tutorial 9 — Advanced formatting

As an example of the kind of professional results you can achieve very easily with Write, we’ll take a look at some powerful additional features.

**Note**: If you are unsure how any piece of text has been formatted, you can select it and then look at the toolbars to see which of the formatting buttons is activated.

**Inserting a picture**

To insert an existing picture or image file into your document, do the following:

Select the **Picture** option from the **Insert** menu.

1. Select **From File** (the other options – New Ability Drawing and New Ability Painting – allow you to use the full facilities of the Ability Draw and Photopaint applications to create a picture from scratch).
2. The “Open” dialog will appear with a list of all the documents in the current folder. Use the folder list to navigate to the folder you want.

3. Once you’ve found the picture file you want, select it and then click on the **Open** button (or double-click directly on the picture file).

4. Now use the **Align** buttons to position the picture either to the left, in the middle or to the right of the page (you can do this at any time in the future but you must click on the picture first to select it).

**Placing borders around text**

We’ll now put some borders round selected text, using the **Borders and Shading** toolbar. (If you cannot see a particular toolbar, open the **View** menu and click on the **Toolbars** option - click in the box to the left of the required toolbar. Click on the **Close** button when you’ve finished).

First select the text you wish to put a border around. Note that borders are applied at the paragraph level - you can put a border around one or more paragraphs but not around individual sentences within paragraphs. The tools for applying borders are listed below.

This is the **Borders and Shading** toolbar, with the Borders tools in the left-hand section:

- Set the border line style for subsequent borders.
- Turn on or off the left, right, bottom and top border lines.
- Turn all borders on.
- Remove border.
- **B** Set color for subsequent border lines.

As an alternative to using the Borders toolbar you can open the “Borders” dialog by selecting the **Borders** option from the **Format** menu. This provides you with extra control over the borders, including the **Offset** (the distance between the border and the text).

The toolbar also contains shading options, which you can read about in the Write Help.

**Setting colors for text**

Color can be used effectively to highlight text you want to stand out. To apply color to any selection of text, do the following:

1. Select the text you want colored.
2. Right-click and select **Font** from the shortcut menu (or from the **Format** menu).
3. On the **Font** page click on the arrow in the **Color** box to display the choice of colors available.
4. Select a color.
5. Click on the OK button to apply the color.

**Paragraph indents and the horizontal ruler**

The paragraph indent settings are set using the horizontal ruler (if this is not displayed, select the Ruler Bars option from the View menu and then select Horizontal).

To set the indent first click in the paragraph to select it. To set the amount of extra indent from the left and right margins, click on one of the indent markers on the horizontal ruler (see diagram) and drag it to a new position. When you release it the paragraph will move to its new location (note that you will have to move the first line indent separately).

![Diagram of paragraph indents](image)

Note that to save time you could set this up as a style. For more details, select Write help from the Help menu and type Styles, using into the index.

**Headers and footers**

We'll now take a look at how to create headers and footers, at the top and bottom of the document pages respectively, into which you can insert page numbers, dates and text.

To create a footer for every page select the Footer option from the View menu. This places the cursor in the footer and displays the headers and footers toolbar. You can now type in any text you wish. The buttons on the toolbar allow you to do the following:

- Insert the page number
- Insert the date
- Insert the time
- Insert the document title

Use these buttons to move between headers, footers and the body text, and to set up the header and footer:

- Move to the header (when in a footer)
- Move to the footer (when in a header)
- Move to the body text
- Setup (use this to set different headers or footers for each page).

Once they've been created, headers and footers can be treated in the same way as text in the body of the page - you can format and style them, add borders, and insert pictures or other objects.
Tutorial 10 – Using Tables

Tables allow you to section off information in a Write document. Since each one is comprised of rows and columns in a grid pattern, tables are also useful in structuring and organizing data. Moreover, you can easily edit and format the tables you have created, add or delete rows and columns, join one table to another, and so on.

In the following tutorial you will be shown how to create, edit, format and enter data into a table.

The example will show a tabulation of the gifts awarded to the four best salesmen of the month. We will also create a similar table for the two best newcomers.

Create the first table:

1. Select **Insert Table** from the **Table** menu
2. In the **Insert Table** box, select 2 columns and 6 rows and then click on **OK**.

Once the table is inserted you can go ahead and enter text and data.

<table>
<thead>
<tr>
<th>Salesmen of month</th>
<th>Award</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jackie Jones</td>
<td>Weekend for two in Paris</td>
</tr>
<tr>
<td>Delia House</td>
<td>Leather bound set of complete works of George Elliot</td>
</tr>
<tr>
<td>Terry Rivers</td>
<td>Fly fishing rod, net and tackle</td>
</tr>
<tr>
<td>Don Sharp</td>
<td>Two bottles of vintage wine</td>
</tr>
</tbody>
</table>

Since the first row contains titles, it is a good idea to format it in bold type and with underlining:

Move your mouse just to the left of the first row (it will display as an arrow) and click. The row will be selected and highlighted in gray.

Right click and select **Bold**, **Underline** and **Center** from the **Format** tools bar.

You can now create the second table, enter the data, and format the first row as above:

<table>
<thead>
<tr>
<th>Best newcomers</th>
<th>Gift</th>
</tr>
</thead>
<tbody>
<tr>
<td>Simon Hammond</td>
<td>Pen</td>
</tr>
<tr>
<td>Jenny Trestle</td>
<td>Pen</td>
</tr>
</tbody>
</table>

Unfortunately it is discovered that one of the salesmen of the month exaggerated his success. Remove Terry Rivers as follows:

1. Select the row on which he appears.
2. Right click, select **Delete** from the short-cut menu, and then select **Rows**. The selected row will be deleted.

It is then discovered that the best newcomers were just as good as the regulars, so it is decided that the two tables should be combined.

1. Click anywhere within the first table.
2. Right-click and select **Join Table** from the menu.

The second table will join with the first to form one table. Note that Join Table always joins the selected table to the next one **below** it in the document. Any text **between** the two tables is then placed **after** the new combined table.

In the combined table delete the title line from the original second table:

Select the appropriate row, right-click, select **Delete** and then **Rows**.
Add an extra column to include the cost of the items:

1. Click anywhere in the last column of the table, right-click your mouse and select **Insert Columns** from the menu.

2. In the "Insert Columns" dialog, set the **Number of columns** at 1 and click on **Insert to the right of current cell**.

You can now add the prices of the items (and change the presents for the best newcomers to something more appropriate). You may also want to center the numbers in the last column.

The final table will be like this:

<table>
<thead>
<tr>
<th>Salesmen of month</th>
<th>Award</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jackie Jones</td>
<td>Weekend for two in Paris</td>
<td>600</td>
</tr>
<tr>
<td>Delia House</td>
<td>Leather bound set of complete works of George Elliot</td>
<td>400</td>
</tr>
<tr>
<td>Don Sharp</td>
<td>Two bottles of vintage wine</td>
<td>300</td>
</tr>
<tr>
<td>Simon Hammond</td>
<td>Pen and CD token</td>
<td>200</td>
</tr>
<tr>
<td>Jenny Trestle</td>
<td>Pen and CD token</td>
<td>200</td>
</tr>
</tbody>
</table>

These are the basics of creating, editing and joining tables. See the Write Help notes (type Tables in the index line) to read up on how to split a table or a cell, and other Table operations.
Tutorial 11 – Creating newsletters

In this section we’ll look at some interesting techniques that can help you to create “newsletters” and simulate other familiar printed formats.

Columns

The text in a newsletter is usually placed in vertical columns, like in a newspaper. To create columns, follow these steps:

1. Select the text you want to put into columns. This may be a paragraph or several paragraphs.

2. Click the Columns button on the format toolbar.

3. Set the number of columns (up to a maximum of six) and click OK.

The text takes the selected paragraphs and places them in order in the columns i.e. you read down the first column, then the second, and so on.

You can now edit the text in the normal way.

Frames

A frame is like a mini page that can be positioned and sized to sit anywhere on top of your standard page. It can contain objects such as pictures or text, formatted in any way you wish. The text in the main body of the document is rearranged to flow round the frame whenever you move it (you can change this to have the non-frame text flow “under” the frame).

To create a new frame follow these steps:

1. Select the Frame option from the Insert menu. The mouse pointer will change to a +.

2. Click and drag the pointer across the document to define the size.

3. Now simply click anywhere in the frame to make it active. It will be displayed with a border and you can now enter and edit text or insert pictures. Click anywhere on the standard page to leave the frame.

Once your frame is in place you can resize or reposition it using the following procedure.

1. Click in a frame so that the frame edges are visible (i.e. to make it active).

2. Click on the frame edge to display the eight resize boxes.

3. Click on one of the boxes and drag to define a new shape.

4. Click anywhere else on the frame edge i.e. not on a box, and drag to a new location.

You can exercise even more control over your frames using the “Frames” dialog, accessed via the Frames option in the Format menu. For more details, select Write help from the Help menu and type Frames into the index.

Tutorial 12 — Using templates

If you create similar documents time after time, you can save a lot of work by defining a template. A template can be used as the basic design or prototype for any new documents you open. Typically a template can include settings for margins, font styles, pieces of text, and most other document features. The template can then act as a new default design for the documents you wish to base on it.
The Normal template is the standard default template. Here we will go through how to create a template based on a document that you have formatted yourself.

1. Select the New command from the File menu.

2. Click on Normal from the list of templates and then click OK to open a new document.

3. Format the document in any way you like e.g. set the margins, insert a date field, insert page numbers into a footer, type in and format text that is likely to be repeated across many documents, etc.

4. Select Save as from the File menu to open the dialog, give the file a name, and select Ability Write Template (.awp) from the drop-down list in the Save as type line. Note that the Template folder is made the current folder in the Save in line at the top of the dialog, hence making sure that the template is always saved to the right place.

5. Click on Save.

Next time you create a new document, just click on the new template to use it as the basis of the document with all the settings you created already there.

Type Templates in the index of Write Help for a full account of the various ways to work with templates.

### Appendix A — Format Toolbar Buttons

To format text, first select it and then use one of the following (arranged horizontally on screen).

<table>
<thead>
<tr>
<th>Tool</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal</td>
<td>Style box</td>
<td>Click on the arrow to display a list of available styles, then choose the one you want for the current paragraph.</td>
</tr>
<tr>
<td>Times New Roman</td>
<td>Font name box</td>
<td>Click on the arrow to display a list of available fonts, then choose the one you want.</td>
</tr>
<tr>
<td>12</td>
<td>Font size box</td>
<td>Click on the arrow to display a list of font sizes, then choose the one you want.</td>
</tr>
<tr>
<td>Bold</td>
<td>Bold button</td>
<td>Emboldens the selected text.</td>
</tr>
<tr>
<td>Italic</td>
<td>Italic button</td>
<td>Italicizes the selected text.</td>
</tr>
<tr>
<td>Underline</td>
<td>Underline button</td>
<td>Underlines the selected text.</td>
</tr>
<tr>
<td>Strike out</td>
<td>Strike out button</td>
<td>Draws a line through the selected text.</td>
</tr>
<tr>
<td>Left Align</td>
<td>Left Align button</td>
<td>Aligns the current paragraph to the left.</td>
</tr>
<tr>
<td>Center</td>
<td>Center button</td>
<td>Centers the current paragraph between the margins.</td>
</tr>
<tr>
<td>Right Align</td>
<td>Right Align button</td>
<td>Aligns the current paragraph to the right.</td>
</tr>
</tbody>
</table>
**Justify** button  Justifies the current paragraph (alters the spacing between the words so that straight left and right margins are created).

**Columns button**  Opens the “Text Property” dialog window at the Columns tab (let's you break up the current paragraph into columns).

**Bullet button**  Selected text is redrawn with bullets preceding the first line of each paragraph.

**Numbering button**  Selected text is redrawn with numbers, in sequence, preceding the first line of each paragraph.

**Increase Indent button**  Moves the current paragraph to the right.

**Decrease Indent** button  Moves the current paragraph to the left.
Ability Spreadsheet

Spreadsheet is Ability Office’s application for analyzing and working with numerical and financial data. With it you can organize and track data, perform calculations, create formulas, find totals and averages, project business trends, experiment with “what if” scenarios, utilize Ability’s extensive range of functions, and much more.

Spreadsheet Tutorials

The following tutorials are designed to take you through the most basic tasks you will need to use Spreadsheet successfully.

Before starting the tutorials you should read the section Getting Help and acquaint yourself with Spreadsheet’s on-line help facility. Any questions you have that aren’t answered by this booklet will almost certainly be answered there.

Tutorial 1 — Getting to Know the Spreadsheet Window

Start Spreadsheet by selecting Start from the Taskbar and then selecting Programs/Ability Office/Ability Spreadsheet. You will be presented with a blank spreadsheet document. We’re going to use this blank spreadsheet to explore the spreadsheet environment.

The spreadsheet window

The area in which you work is called the spreadsheet window. The different parts are shown in this diagram:

A spreadsheet is organized into rows and columns, like a table. The rows are numbered down the left edge of the spreadsheet window. The columns are labeled with letters across the top of the spreadsheet window.

Cells and cell ranges

The spot where a row and column intersect is called a cell. A cell is the place in a spreadsheet where you enter text, numbers or formulas.

Each cell in a spreadsheet has a unique identifier, called a cell address.

For example, here January appears in the cell C4, where column C and row 4 intersect:
A range is simply a group of cells. For example, the cells A1, A2, A3, A4, A5 can be referred to as a group by using the following notation:

A1..A5

Selecting cells

Click on any of the cells in the spreadsheet window; you’ll notice a black highlight appears around the cell showing you that it’s now the active cell. In the above diagram the active cell is B2.

Clicking on a column letter on the column bar selects that column, while clicking on a row number on the row bar selects that row (selected rows or columns become highlighted in inverse colors). You can select multiple rows or columns by dragging the cursor across several row or column bars, or you can select the entire sheet by clicking the button at the intersection of the row and column bars.

Moving around a spreadsheet

To move around a spreadsheet, you can either use the mouse to click where you want the cursor to go or move the cursor directly with the arrow keys on the keyboard.

If you are working on a larger spreadsheet, you can either use the scroll bars at the right and bottom of the screen to move vertically and horizontally respectively through the spreadsheet or use the Go To command from the Edit menu to jump straight to the cell you want.

Tutorial 2 — Entering data into cells

Every cell is comprised of two features: its contents and its formatting.

Assigning cell contents

Across the top of the window are the various toolbars containing the buttons and drop-down lists that enable you to format and manipulate the cells and figures quickly and easily. The lower bar is called the formula bar; this is where you enter text, numbers and formulas into the current cell.

Type some text in the box, your first name say, then press the Confirm button. Your text should now appear in the active cell - you have now assigned the contents for that cell.
Assigning cell formatting

Now with that cell still active you can specify how you want the cell contents to appear, using the buttons on the format bar (above the formula bar). Many of the formatting tools will be familiar if you have used a word processor, but there’s a full listing in Appendix B at the end of this booklet.

Note: You format a single cell or range of cells in the same way.

Closing a spreadsheet

Look at the top right-hand corner of the screen, there are two Close buttons \[\times\]. Clicking on the top one will close down Spreadsheet; clicking on the one beneath that will close down the current spreadsheet. Do the latter. A dialog window will open asking you if you wish to save the spreadsheet. Since we’ve just been warming up so far, click on No.

Creating a new spreadsheet and giving it a name

First click on the New button \[\text{New}\] on the left of the standard toolbar (the one above the format toolbar). Now click on the Save button \[\text{Save}\] to bring up the “Save as” dialog window. Enter a new name, “Profits” say, in the File name box and then click Save. Your spreadsheet will be saved under this name in the currently selected folder (the “My Documents” folder is the default current folder).

Note: It is recommended that you save your work often (to minimize what you may lose in the event of a power cut or system crash). Simply click on the Save button \[\text{Save}\] whenever you wish to save your work.

Entering and formatting headings

First click on the D3 cell and then type “Income” (note that though we’ve picked D3 it doesn’t really matter whereabouts on the spreadsheet you place your data). Now press the right cursor movement key on the keyboard. This performs the same action as when you click on the Confirm button \[\text{Confirm}\], except that the active cell moves to the right – E3 now has the highlighted outline. Type “Expenditure”, press the right cursor movement key again, type “Profit” and then press the Confirm button \[\text{Confirm}\].

Next, click in the D3 cell and drag the mouse along to the F3 cell so that the three words are highlighted. Click on the Bold button \[\text{Bold}\] and the Center button \[\text{Center}\] so that they stand out.

Drag and fill

Next we’ll need a vertical column listing the months of the year. Enter the abbreviation “Jan” in the C4 cell. We’re now going to use a shortcut technique called drag and fill to add all the other months below this. Follow these steps:

1. Click into the source cell (C4).
2. Move the mouse pointer over the cell handle in the bottom right corner of the cell:

```
| Jan |
```

3. When the mouse pointer turns to a cross, hold down the left mouse button and drag the cell outline down to C15.

The contents of the source cell will **fill** the selected cells with the twelve months in ascending order.

Numbers, days and months can all be entered using the drag and fill method - for more details select Spreadsheet help from the Help menu and type *Drag and Fill* in the index.

### Entering some figures

Now we'll produce two columns of numbers to get income and expenditure figures for every month. You enter values in the same way as you enter text: point to the cell where you want the value to appear, then type it in. It’s faster working through long columns of numbers if you simply press return instead of using the **Confirm** button.

**Note:** Values are automatically put to the right of cells (this is to make sure that columns of figures line up neatly), though you can change this alignment if you prefer another.

### Entering currency values

You should now have two columns of figures running from D4 to E15. Highlight this range and then click on the **Currency** button to label each figure as a currency value. Click on the Commas button to put a comma after thousands i.e. after every three digits.

### Tutorial 4 — Formulas

Formulas are the real heart of the spreadsheet. You can use formulas to perform all manner of calculations based on the numbers in your spreadsheet. In our spreadsheet we're going to use a simple formula to calculate the income less the expenditure i.e. the profit.

### How to enter a formula

Formulas are entered in the active cell just as you enter text or values. However, you always start a formula with an equals sign (=), which lets the Spreadsheet know that the following expression is to be evaluated. After that you build a formula using standard arithmetical expressions, for example, "+" or "-", and by making reference to other cells. (See Formulas in Spreadsheet Help.)

Click in the F4 cell then type

```
=D4-E4
```

When you click on the **Confirm** button, the difference between the income and expenditure for January appears in the F4 cell.

**Note:** If you were now to go back and change one of these figures the contents of F4 would automatically be updated.
Copying a formula

Now we're going to work out the profit for every month but to do this we'll use a handy shortcut to copy our formula from one cell to another. First make sure that F4 is the active cell and then click on the **Copy** button from the toolbar. Next, select the cells from F5 to F15 and click on the **Paste** button on the toolbar. The profit for every month of the year is now listed.

If you click on any of these cells and examine its formula in the formula bar, you will notice that it has been altered slightly from cell to cell. This is because Spreadsheet automatically adjusts the cell addresses in the formula so that they work logically in the new location. So, for example, F5 is calculated from D5-E5.

You can now format the Profit column by selecting the range F4..F15 and clicking on the Currency and Commas buttons, as was done above for the other columns.

**Tutorial 5 — Formulas using absolute addresses**

Sometimes you might want to define a constant, that is a fixed value that can be referenced by any other cell, and which can be changed easily as required. An example might be the interest rate at a bank. Its value naturally fluctuates but you wouldn't want to go through your banking spreadsheet and update each cell that calls on the interest rate every time the rate changed. It would be far better to store the value of the constant in a particular cell and then update that cell when necessary.

However, as discussed in the last tutorial, when you paste formulas, Spreadsheet normally adjusts the cell addresses so that the formula works in the new locations. So how do we ensure that the cell address where our constant is stored remains fixed during pasting? The answer is *absolute addresses*.

**Absolute Addresses**

Say our imaginary company had a profit share scheme whereby a certain percentage of the profits, let's say 5% to begin with, was distributed amongst the employees as a monthly bonus. One way of calculating the size of this bonus is as follows:

Create a new heading, “Profit Share”, in H3. Click in the cell I3 and enter the value 0.05. Click on the **Confirm** button and then click on the **Percentage** button on the formatting toolbar (notice that percentages are entered in decimal notation e.g. 50% is entered as 0.5; 5% as 0.05).

Click in H4 and enter the formula:

```
=F4*$I$3
```

The dollar sign preceding the “I” and the “3” indicates that this an absolute row and column address. It tells Spreadsheet to copy that part of the formula exactly, leaving the field address unchanged. Now when you paste the formula into the range, all the cells in the range will reference the I3 cell. Modify the contents of that one cell to see what effect this has on the profit share pay out for every month of the year.

Your spreadsheet will now look something like this:
Once again you can format column H for currency and commas.

---

**Automatic Totals**

Summing values in a column, row or range is a function so commonly used in spreadsheets that a button, the **Sum** button $\sum$, is provided on the standard toolbar to make the process easier. Say we wanted to display the total expenditure of our company over the year, we would follow this process:

Highlight the cell range (E4..E17), which includes the monthly expenditure. Click on the **Sum** button $\sum$.

The total of the twelve monthly expenditures will be pasted in the bottom cell (E17). To complete the exercise, embolden the total so that it stands out.

---

**Built-in functions**

Spreadsheet provides you with a list of over 200 built-in functions. These can be placed in your formulas and are accessed by clicking on the **Functions** button $\sqrt{\text{/functions/}}$. To explore their use we’ll calculate the average monthly income for our company over the twelve-month period.

---

**Naming a range**

The income data for which we wish to work out the average resides in cells D4 to D15. We could refer to this range in our formula as “D4..D15”. However, it is a good habit to give the range a meaningful name. Both cells and ranges of cells can be assigned names - once you’ve done this you can use the assigned name in formulas, instead of the more cumbersome cell addresses.

1. Click on D4 and drag the mouse down to D15.
2. Select **Range Name** from the **Insert** menu, then type “Cash_In” into the name box. Notice the underscore used between the two words – range names can’t contain spaces.
3. Next, click on the **Add** button to add the new name to the list of named ranges
4. Click on the **Close** button to finish.
Functions and arguments

Click on a free cell away from the rest of your data, A16 say, and then click in the text box on the formula bar. Click on the Functions button – an alphabetical list of functions is displayed. Click on one and you’ll notice a brief description of the function appears underneath, along with the format that the function should appear in. Most functions have one or more arguments, that is, variables into which data is inserted so that the spreadsheet can calculate the function’s result. A good example is DAYS360, a function that works out the number of days between two dates based on a 360 day year. It has two arguments: the start date and the end date.

Getting back to our spreadsheet, click on the Statistical tab, select the function named AVERAGE, and then click on OK. The following text will have been inserted in the function bar text box:

\[ \text{=AVERAGE()} \]

The cursor is flashing between the brackets ready for you to enter the argument, that is, the list of cells whose average you wish to calculate. Type in “Cash_In” and then click on the Confirm button. The average monthly profit appears in the A16 cell. You can edit format this to display currency, commas, decimal places, etc. Don’t forget to place a title in A15 (e.g. “Avg Monthly Income”), so that it’s clear what the figure represents.

Tutorial 7 – Worksheets

Each spreadsheet is comprised of worksheets, which help you to structure and separate related data. These are numbered along the bottom of the spreadsheet window: Sheet1, Sheet2, Sheet3, … with the current worksheet selected. Ability Spreadsheet allows you to use up to 255 worksheets in any one spreadsheet file.

The great advantage of worksheets is that they allow you to hold together in the one spreadsheet related data that you nonetheless want to keep apart, but at the same time connect the data through formulas that work across the worksheets.

Each of the worksheets is displayed in the familiar spreadsheet layout. By default there are 15 worksheets immediately available for you to work in when you open a spreadsheet file, with Sheet1 as the current worksheet. To display all these position your mouse pointer over the right-hand edge of the last visible sheet name in the row. When the pointer turns to a cross click and drag to the right to display higher sheet names.

The following tutorial takes you through a calculation across two worksheets, and shows you how to rename, move, add and delete worksheets.

Using the previous example on Sheet 1, we will make a summation of the values in the first column and place the result in cell A1 of Sheet 2.
First, note that the general formula for making a calculation from one sheet to another is this:

`=sheetname!cell`

For example,

`=Sheet1!A1`

entered in any cell in any sheet in the spreadsheet will access the data in cell A1 of Sheet1.

Any formula involving a sheet can also be used in a larger formula:

`=Sheet5!D4 * 2`

takes the data from cell D4 in Sheet 5 and multiples it by 2.

In our example we want to sum up the values in the range D4 to D15, which will give a total income from January to December. This can be done by summing these figures in Sheet 1 using the Sum button on the toolbar and then making a reference from Sheet 2 to the sum cell; or by actually calculating the sum from Sheet 2 by using a formula that refers to the appropriate range in Sheet 1. To refer to a range, you just prefix the range with the sheet name and exclamation mark.

Thus in our example, first click on Sheet 2 and then enter this formula in cell A1 of Sheet2:

`=SUM(Sheet1!D4..D15)`

to get the result $49,022.

If you have already summed the same column directly in Sheet 1, putting the result in D16, you would bring the result over to Sheet 2 in a simple formula:

`=Sheet1!D16`

In future, whenever you change any of the values in the range in Sheet 1, the result in Sheet 2 will be updated automatically.

A cell in one sheet that calls on the data in another can also be referred to in a third sheet, and so on.

You will probably want to give some of your worksheets more informative titles:

1. Right-click on Sheet 1
2. Select Rename from the drop-down menu to open the “Rename Worksheet” dialog.
3. Type in the new name: for example, Profit.
Sheet1 along the bottom will become Profit.

Note that there is no need to worry about formulas that use the old sheet name: these are automatically updated with the new name.

You don't have to stick with the given order of the worksheets:
1. Right-click on Sheet1 (or Profit, as we have renamed it)
2. Select Copy/Move from the drop-down menu

In the “Copy or Move Worksheets” dialog follow these steps:
1. In the Copy/Move selected sheets box make sure that the relevant sheet is selected (since you right-clicked on Profits it should be selected anyway).
2. All the sheets are listed – in order – in the Before sheet box. Select the sheet before which you want to copy or move Profits.
3. Choose whether to copy (duplicate without deleting the original) or move (duplicate and delete the original) by selecting either the Copy (you’ll need to enter a new name for the second copy) or the Move button.

The order of the sheets will change there and then, so you can continue in the same dialog to make all the moves you like.

When you’re finished, click on OK to close the dialog.

Note that there is also an option to copy or move to a completely different spreadsheet (see the Spreadsheet Help notes for more information).

Again, by right-clicking you can use the same drop-down menu to Delete the current worksheet, Insert a new worksheet (up to 255 in total), Rename the current worksheet, and give a Color to the current worksheet (a palette will be displayed from which to choose a color).

**Tutorial 8 – Styles**

A useful feature of Spreadsheet is the ability to combine various formatting options into the one operation. These operations are called *styles* and each one can be applied, anytime you need it, to any range of cells.

The following tutorial shows you how to create a style that will format a number in various ways.

Right-click your mouse and select Format Cells from the drop-down menu (alternatively, select Cells from the Format menu).

In the “Format” dialog box, click on the Styles button at the bottom right corner to open up the Styles Design box (this is the box on the right-hand side).

You can now use any combination of the six basic format options (accessible through the six tabs along the top of the box) to help design the new style:
Number, Alignment, Font, Border, Color, Cell Attributes.

We'll format a number so that it is recognized as a weight (kg), with thousands separated by commas and three decimal places to measure grams, placed on a red background, and aligned to the center of the cell.

1. Select the **Number** tab and then select **Number** from the list. Click on **Thousands with Commas**, make **Decimal Places** 3, click on **Trailing** and select kg from the drop-down list.

2. Next, click on the **Color** tab and select red from the palette.

3. Click on the **Font** tab and select **Bold** in the **Font style** box.

4. Finally, click on the **Alignment** tab and select **Center** in the **Horizontal** box.

You now need to define the style:

1. Click in the line above the main box on the right and type a name for the style, say, Weights.

2. The **Add** button will be activated. Click on this to insert the new style in the box below.

All your styles are stored here, ready for you to use at any time. Every time you want to apply the Weights style (whether to a single cell or a selected range), just open up the “Format” dialog, select Weights and click on **Apply**.

Try it. Type 1234.245 and enter it in a cell. Apply the Weights style to get: **1,234.245 kg** on a red background.

You can go back to the “Format” dialog box at any time to design new styles or apply old ones. Also, you can delete a style by selecting it and clicking on the **Remove** button.
A chart lets you represent the data on your spreadsheet graphically. There are several chart styles to choose from and a single spreadsheet can contain many different charts. We're going to create a "columns" chart representing our company's monthly income, expenditure and profit over the year.

Creating a chart

1. Select the range C3..F15. Note that this covers the relevant data, the column of months and the row of data headings.
2. Select Chart from the Insert menu.
3. Choose On This View to insert the chart into the current spreadsheet (As New View places the chart in a new window which is attached to the spreadsheet).

In the "Chart" dialog there are several pages to help you set the style, range, color, etc. of the chart. We will go through the steps to create one type of chart (see Spreadsheet Help for further information on using charts).

1. On the Chart Data page of the dialog, type in a name in the Chart Name box, say, Profits.
2. The range in the Data Range should be C3..F15, that is, the range you previously selected. Although we will not do so, you can change the range at this point. For instance, if you want to chart just the profit against months you would type in C3..C15, F3..F15 to restrict the chart to the relevant columns.
3. Make sure that Columns is selected in the Series run in box, Labels in the First column contains box, and Labels in the First row contains box. (The latter two choices ensure that the months and headings are treated as labels rather than data, and the former ensures that the three data columns are treated as three series with their associated data points.)
4. Click on Next to go to the Style page.
5. Select Column in the Chart category box and Vertical in the Chart style box. A preliminary view of what the chart will look like is displayed in the Preview box to the right. Note that the three series – Income, Expenditure, Profit – are grouped together by month, with each series in a different color, and that every month is represented.
6. Click on Next to go the Title page.
7. Select Top title in the Title box and make sure that Disabled is switched off (blank, so that titles are displayed).
8. Type a title – say, Yearly Results – in the Title text box to give the chart a title which will appear above the chart. (The title can also be given a different font and alignment by clicking on the Change font button).
9. Click on Next to go to the Legend page.
10. In the Legend box make sure that three of the legends – Top, Left, Right – are Disabled (make sure that the box is ticked) and that the Bottom legend is activated (the Disabled box is blank). The legend will appear below the chart in the preview box and will show the names of the series and their respective colors.
11. Click on Next to go to the Chart Series page (we’ll ignore this for now) and then click on Finish to insert the chart into the spreadsheet.
12. In future, you can edit all the chart attributes by right-clicking over the chart and selecting one of the options from the drop-down menu. This will take you into the “Chart options” dialog, where you set a wide range of attributes.

This is what the chart looks like, though bear in mind that we can’t here show the colors for the columns and the legend:

### Yearly Results

Resizing and moving an embedded chart

Now that your chart is embedded in the spreadsheet you can change its size or positioning until you’re happy with it. Click once in the main body of the chart and handles will appear at various places along its border.

*Move* the chart by holding down the left-hand mouse button when the cross cursor is showing over the body of the chart. Drag the chart outline to the new position and release the mouse button.

*Resize* the chart by pointing at one of the handles and holding down the left-hand mouse button when the cursor changes to a double-headed arrow. Drag the border till it is the size you require and then release the mouse button.

For more information on charts, select Spreadsheet help from the Help menu and type *Charts* into the index.

---

**Tutorial 10 — Printing your spreadsheet**

**Printing**

You can print a copy of your spreadsheet onto paper by clicking on the Print button on the toolbar. This opens up the “Print” dialog, in which you can choose which pages of the spreadsheet to print, how many copies and their order, and select a particular printer to print from. Click OK to print.

**Print setup**

Before printing you may want to set some other options in Print Setup from the File menu:
In the “Print Setup” dialog you can choose which printer, paper size and orientation you want to use and which bin you want the paper to feed from. In addition, there are scaling and print-to-fit options available. These help you to control the appearance of your spreadsheet when it is printed.

Set up the scaling options in the Scaling section as follows:

- Select the Adjust to button to reduce or enlarge the printed spreadsheet by percentage of the normal size. Set the percentage in the % normal size box by either typing it directly or using the scroller.

- Select the Fit to button to make the printed spreadsheet fit onto a specified number of pages. Enter the required pages, by width and height, in the accompanying boxes (or use the scrollers). Typically, if you want to fit the spreadsheet onto 1 page, leave the boxes set at 1 for both width and height.

Click on OK once you have selected your print settings.

**Print Preview**

It is a good idea to check what your spreadsheet will look like before printing to paper. To do this, click on the Preview button on the toolbar. The display switches to print preview mode, in which the spreadsheet is shown at a reduced size, to give you an overall view. If you are happy with the layout press the Print button; if you wish to make some more changes first, then click on the Close button.

If you have any trouble printing, but can’t find the solution in Spreadsheet Help, it may be necessary to check your printer documentation, or Windows help, for more details.

### Appendix A — The Standard Toolbar

<table>
<thead>
<tr>
<th>Tool</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="New" /></td>
<td>New button</td>
<td>Opens a new, blank spreadsheet.</td>
</tr>
<tr>
<td><img src="image" alt="Open" /></td>
<td>Open button</td>
<td>Opens an existing spreadsheet.</td>
</tr>
<tr>
<td><img src="image" alt="Save" /></td>
<td>Save button</td>
<td>Save the current spreadsheet.</td>
</tr>
<tr>
<td><img src="image" alt="Print" /></td>
<td>Print button</td>
<td>Prints the current spreadsheet.</td>
</tr>
<tr>
<td><img src="image" alt="Print Preview" /></td>
<td>Print Preview button</td>
<td>Use this before printing to see how your spreadsheet is going to look on paper.</td>
</tr>
<tr>
<td><img src="image" alt="Spell checker" /></td>
<td>Spell checker button</td>
<td>Searches your spreadsheet for any misspelt words and tries to suggest the correct spelling if it finds any.</td>
</tr>
<tr>
<td><img src="image" alt="Cut" /></td>
<td>Cut button</td>
<td>Removes the selected text from the spreadsheet and places it on the computer’s clipboard.</td>
</tr>
<tr>
<td><img src="image" alt="Copy" /></td>
<td>Copy button</td>
<td>Copies the selected text from the spreadsheet and places it onto the</td>
</tr>
</tbody>
</table>
Appendix B — Format Toolbar

The format tools can be used to change the appearance of your spreadsheet. To format a cell (or a range of cells) first select it and then use one of the following (displayed horizontally from left to right on screen).

- **Paste button**: Inserts the contents of the computer’s clipboard at the cursor.
- **Fill Format button**: Click on this button; click on a cell whose formatting you wish to copy; then click on the cell or range of cells that you wish to paste the formatting into.
- **Undo button**: Undoes the last action you performed.
- **Redo button**: Redoes the last undone action.
- **Repeat button**: Applies the last formatting action to the current selection.
- **Find button**: Searches the spreadsheet for any numbers or text that you specify.
- **Replace button**: Same as above except you also specify numbers or text to be used as a replacement.
- **Fill button**: Fill a range of cells with a sequence of numbers or plain text.
- **Sum button**: Instantly adds row and column totals to the selected range.
- **Edit Source button**: Converts a one-way link between two cells into a two-way link, and vice versa. See Spreadsheet Help.
- **Zoom box**: Sets a magnification at which to view the spreadsheet.
- **Zoom in, Zoom out buttons**: Increases/decreases the magnification at which the spreadsheet is viewed.
- **What’s this button**: Click this and then point and click on any part of the application window to view specific help on that item.
<table>
<thead>
<tr>
<th>Tool</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Font Name box</td>
<td></td>
<td>Sets the font for the current cell/s. Click on the arrow on the right to display a list of available fonts, then choose the one you want.</td>
</tr>
<tr>
<td>Font Color box</td>
<td></td>
<td>Sets the font color for the current cell/s. Click on the arrow on the right to display a color palette from which to choose.</td>
</tr>
<tr>
<td>Font size box</td>
<td></td>
<td>Sets the font size for the current cell/s. Click on the arrow to the right, then choose the font size you want.</td>
</tr>
<tr>
<td>Bold, Italic, Underline and Strikeout buttons</td>
<td>Emboldens, Italicizes, Underlines, or draws a line through text in the current cell/s.</td>
<td></td>
</tr>
<tr>
<td>Left Align, Center, and Right Align buttons</td>
<td></td>
<td>Aligns the contents of the current cell/s to the left, center or right.</td>
</tr>
<tr>
<td>Top, Middle and Bottom buttons</td>
<td></td>
<td>Sets the vertical alignment for the contents of the current cell/s.</td>
</tr>
<tr>
<td>Wrap button</td>
<td></td>
<td>Wraps the text within the cell (switches the cell from a single line to as many lines as it needs to fit all the text within it).</td>
</tr>
<tr>
<td>Currency button</td>
<td></td>
<td>Add currency format to cell</td>
</tr>
<tr>
<td>Percentage button</td>
<td></td>
<td>Add percentage format to cell.</td>
</tr>
<tr>
<td>Commas button</td>
<td></td>
<td>Format thousands with comma separator.</td>
</tr>
<tr>
<td>Decrement precision button</td>
<td></td>
<td>Increase number of decimal places by one.</td>
</tr>
<tr>
<td>Increment precision button</td>
<td></td>
<td>Decrease number of decimal places by one - the numbers will be rounded to the nearest decimal place.</td>
</tr>
<tr>
<td>Lock and Hide buttons</td>
<td></td>
<td>When the spreadsheet is protected, Locking a cell prevents the cell from being changed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>When the spreadsheet is protected, Hiding a cell means that its value will not be displayed, either in the cell itself or on the status bar. Note that hidden cells should also be locked.</td>
</tr>
</tbody>
</table>
**Format Border button**

Sets a border for the current cell/s. Click on the arrow to choose which borders to apply.
Ability Database

Database is the database application from Ability Office. A database is a collection of information or data. The Ability Database provides an easy environment to manage all your data requirements.

Database Tutorials

The following tutorials are designed to take you through the most basic tasks you will need to use Database successfully.

Before starting the tutorials you should read the section Getting Help and acquaint yourself with Database’s on-line help facility. Any questions you have that aren’t answered by this booklet will almost certainly be found in there.

Tutorial 1 — Building a simple database

Begin by opening up Database: Click on Start on the Status Bar, then select Programs/Ability Office/Ability Database.

We’re going to create a database to store phone numbers, basically a phone book; it’s going to be short and simple but it will take you through all the fundamentals of setting up a database.

Creating a new database

To create a new database:

1. Click on the New button on the toolbar.
2. The "Create new database" dialog is displayed. The Save as type box should automatically be set at Database Files (*.adb). In the File name box, type the name of the new database: call it “phonebook”.
3. Click on the Save button. Your Database will be saved under this name in the currently selected folder (the “My Documents” folder is the default current folder).

After saving, the dialog is closed and the Database Manager window is displayed. A database tree is created for the new database and you are now free to create the tables, queries, relations, reports and forms that are to go into the new database.

Note: Any edits you make are always saved by the database automatically, so you don’t have to save during normal add, edit or delete operations. When creating complex forms or reports however, it is a good idea to click on the Save button whenever you wish to back up what you’re doing.

Database Manager

Database Manager is where you manage all the objects that make up the database: tables, relations, queries, forms and reports. You can use it to create, delete, restructure and open all of these database objects.

Database Manager lists all the database objects in a tree structure - individual branches (once you’ve created them) can be opened and closed, revealing more detail as required. To open a branch, click on the “+” sign before the database object name.
Tutorial 2 — Creating a new table

Tables are the fundamental database objects. It is here that your data is stored. A table is arranged in rows and columns. Each row will contain all the data for one entry in your phone book, and is called a record. Each column will contain all the data of a particular type for all the entries in your phone book (such as surnames) and is called a field.

To create a new table, right-click anywhere in the Database Manager window and select New and then Table from the displayed menu.

The “New Table” dialog is displayed. This contains a Table Wizard option (which lets you choose pre-designed fields from a selection of template tables) and a Blank Table option. Click on the Blank Table button and the “New table” design window is displayed. The design window is where you create the structure of your table, that is, the framework in which you will store your data.

For each field you need to assign a name in Name and a data type in Type, these being compulsory. In addition, we’re going to assign a caption in Caption. Here’s the procedure and some explanation:

Name

Each item of information that you wish to store, manipulate or extract, must be uniquely accessible by the entire Ability system. You specify this unique field name in the Name cell.

Click in the first empty row in the Name column and enter the field name “first name”.
Type

Ability understands many types of information, including text, numbers, dates, times, and pictures. It recognizes that all of these different types of information have unique requirements for data entry, storage and formatting. When you create a field in the design window, you must choose one of the eleven standard data types. You do this by clicking on the arrow to open the drop-down menu of data types.

Press the Tab key to move into the Type column: the Character data type is the default (being the most common type of field) so we don’t even have to search through the list.

For more details on the different fields available to you, select Database help from the Help menu and type Data Types into the index.

Caption

The caption is the name that will appear above the field when the table is open. If the Caption cell is left empty the name above the field will be the same as that in Name. Remember though that the caption is a sort of nickname, whereas the name given in Name is the official one (this is important when you need to call on this field from other documents or applications).

Press the Tab key to move into the Caption column and enter the caption “First name”.

Adding enumerated field types

Follow the above procedure to put four more fields into the table, each one in a new row. The entries should be as follows:

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Caption</th>
</tr>
</thead>
<tbody>
<tr>
<td>last name</td>
<td>Character</td>
<td>Surname</td>
</tr>
<tr>
<td>home number</td>
<td>Character</td>
<td>Phone Number (Home)</td>
</tr>
<tr>
<td>work_number</td>
<td>Character</td>
<td>Phone Number (Work)</td>
</tr>
<tr>
<td>category</td>
<td>Enumerated</td>
<td>Personal or business?</td>
</tr>
</tbody>
</table>

The “New Table” dialog should look something like this:
Notice that the last field, “category”, has a different data type to the rest. An enumerated field is one that limits the values that can be put into the field to a pre-defined set, these being defined by you. We’re going to use it here so that you can categorize all the entries in your phonebook as either business contacts or as friends and family members.

1. Make sure you’re still clicked in one of the “category” field cells and click on the **Format** button to display the “Format Field” dialog.

2. Next, click on the **Format** tab to display the **Values** box.

3. In the **Values** box type the members of the enumerated set:

   Personal
   Business

Notice that the values must be on separate lines and that to move from one line to the next you need to press **Ctrl-Rtn**, both keys depressed at the same time, on your keyboard.

4. Click on **OK** to save the new information and close the "Format Field" dialog.

**Saving a new table**

When you have defined all five fields, you can give the table a general description in the **Table Description** box - call it “Business & Personal Phonebook”. Finally click on **OK** to create the new table.

Since this is the first time we have saved the table, a "Save As" dialog is displayed. Enter a name for the table, such as “Full Phonebook”, and then click on the **OK** button. The new table name will appear in the list of tables in **Database Manager**.
Tutorial 3 — Adding records

Open your new table by double-clicking on the table name in Database Manager. The table is opened in Grid View (also known as browse mode): every row is a record and every column is a field. This is the view used to add and delete records and generally edit the table's contents; consequently the menu bar changes to provide you with easy access to the various commands you will need. Now you should fill in a few records with the details of some of your friends and work contacts. Don't worry if you don't know a particular item of information (e.g. a business contact's home phone number), just leave the field blank.

Adding records

Whenever you open a table, the last row of the table is always a new record (i.e. blank); it is referred to as the new row and indicated by a star icon in its row bar (the gray box to the left of the first column). Adding a new record is therefore just a matter of typing data into the new row. Click on Add Record in the Record toolbar to move to the first column in the new row (as it's a new table, you don't really need to do this but it shows that this button can be used anytime). You can now enter data in the fields of the new record. When you come to the last field, “category”, click on the arrow and all the valid values for that field are displayed (in this case either “Personal” or “Business”). Click on one of these to record whether the phone number is personal or business.

When the record is complete click on Add Record and begin again. Repeat this process until you have a handful of phone numbers stored and your table looks something like this:

![Table: Full Phonebook]

Notes:

- If you realize you've made a mistake somewhere in an earlier record, simply click on the relevant cell to make it active and then amend the contents as you wish.

- If you don't have all the information on a certain person, a work phone number for instance, simply leave that field blank.

Duplicating records

This is useful if you are adding two people who share the same phone number to your database.

Rather than re-type repeat details, select the whole record by clicking in its row bar and then select the Duplicate Record command from the Record menu. A duplicate of the current record is created.
which you can then edit for the particular entry without having to retype the phone number. (This is especially useful when the repeat information is a whole address.)

Deleting records

To clear a record (i.e. empty out its contents, leaving an empty row) click anywhere in the record and then select Clear from the Edit menu.

If you want to delete a record and the row it occupies, click anywhere in the record to make it the current one and then click on the Delete button on the Record toolbar. The "Delete" dialog is displayed with Current Record selected. Click on OK. You will be warned that you cannot recover deleted records and asked to click Yes to continue with the deletion. The table will be redrawn with the deleted record removed.

Note: If you want to delete several records at once (along with their rows), you can select these records by clicking your mouse on the left row bar and dragging till the required records are all selected. Click on the Delete button. This time All Marked Records is selected within the "Delete" dialog. If you just want to clear a group of records (leaving the cleared rows intact) you should select Clear from the Edit menu.

For more details, select Database help from the Help menu and type Deleting records into the index.

Tutorial 4 — Customizing the look of your table

Changing the column width

Notice that the caption of your “category” field is probably too long to fit in the cell. We’re going to change the width of the column so that the caption doesn’t get truncated:

1. Position the mouse pointer over the right-hand edge of the “category” column bar.
2. When the pointer turns to a cross, hold down the left mouse button and move the cross to the right until the entire caption is to the left of it.
3. Release the mouse button and the column will be redrawn with its new width.

The new column width will be saved with the table and so will not be lost when you leave the database.

Changing the grid style

To alter the way grid view displays your table, select the Options command from the Tools menu. The “Options” dialog is displayed, turned to the Grid Display page. Click in the Vertical Lines tick box to turn these off - that way the individual fields of the records in your phonebook won’t have vertical lines separating them. You can experiment with the other options (the changes you make are shown in the Preview box). Click on Cancel to scrap your changes or on OK to redraw your table with the new Grid Style settings.

Formatting fonts and color in a table

Now we’re going to emphasize the two name columns with some formatting. Click on the column bar at the top of the “First name” column and drag the mouse over to the “Surname” column. Both columns should now be highlighted.

Select Style from the Format menu. The "Format Columns" dialog is displayed, turned to the Font page. In the Outline box set the font style to Bold. Feel free to experiment with the other formatting options (note that the effects of any changes you make are displayed in the Preview box).
Now we’re going to set a different background color for the two name columns. Click on the **Color** tab to turn to the **Color** page of the "Format Columns" dialog. Click on the light gray color button in the **Foreground** palette (note that you can also apply 3D effects and combine different colors by experimenting with the **Background** palette and the patterns available in the pattern drop-down box, but for now we’ll settle for our simple gray highlight).

For more details, select Database help from the Help menu and type *Formatting a table for color* into the index.

When you have finished, click on **OK** to apply the new formatting to your table - the names in your table grid should be displayed in bold on a gray background.

### Tutorial 5 — Forms

A form is an alternative view of a database table. In a form the data is displayed one record at a time in whatever layout you want.

### Opening an auto form

Click on the **View Form** button on the toolbar to create an **Auto Form** based on the current Table Grid View (note that if you’ve previously created and saved a form based on the current table, then the “Choose Form Type” dialog is displayed to give you the option of opening an existing form).

The auto form will look like this:

![Form1](image)

### Design mode

Now let’s make some changes to improve the layout of our form. Forms always open in Browse mode (this is where you view and edit records), but we need to enter Design mode so that we can make some modifications to the layout.

Click on the **Design** button on the toolbar and the toolbar changes to the Draw toolbar. Now you can resize form fields or move them to different locations in the form: click on the field and drag the handles to resize; or move the field, when the crossed arrows appear, by dragging and dropping the whole field at a new position. The exact layout is up to you, but you probably want to put the first name and surname side by side at the top of the form and the two phone number fields together somewhere else.
For more details, select Database help from the Help menu and type Design mode into the index.

When you’re happy with your form’s layout, click on the Save button. You will then be asked to give the form a name - call it “Full Phonebook form”. Click on OK once you have done this.

**Tutorial 6 — Browsing forms**

You use browse mode to actually work with the data from your database table. In browse mode you can page through your records, edit, add and delete records, create filter queries to select subsets of records, hide and show fields, and apply sort orders. These operations are the same as those you use when working in Table Grid View.

You can switch to browse mode, if you are in design mode, by clicking on the Browse button on the toolbar.

You can use the four movement buttons on the browse Record toolbar to move forwards and backwards through the records in your table:

- Next
- Previous
- First
- Last

**Editing records**

To move around in a form, you would usually use the mouse and click to put the cursor where you want it (you won’t need to here, but if the form is very large you can use the scroll bars at the right and bottom of the screen to view more of the form). You can edit the contents of fields by moving the cursor to them and typing in new information.

Any changes you make will automatically be saved. You can reverse the changes you’ve made to the current field by clicking on the Undo button on the toolbar.

**Tutorial 7 — Looking up names in your phonebook**

To look up a name of a person in your phonebook, follow these steps:

1. Click on the Find button on the toolbar to display the “Find” dialog.
2. In the Find what box type the name you wish to search for - either the first name or surname.
3. In the Direction box choose All to search both up and down from the current position.

Click on the Find Next button to begin the search. Ability will bring up the next record containing that name. If it is not the person you want, click on Find Next again to go to the next occurrence, and so on till you have found the name you want or there are no more occurrences of that name.

**Note:** This also works in Table Grid View.
Opening your form in the future

Now we’re going to close down our form and return to the Database Manager. Look at the top right-hand corner of the screen. There are two Close buttons [x]. Clicking on the top one will close down Database; clicking on the one beneath that will close down the current database component (in this case our form).

Looking at the Database Manager you can see that the table, “Full Phonebook”, and form, “Full Phonebook form”, that we created are both listed in the database tree, under Tables and Forms respectively.

If you want to look up a phone number later on, just double-click on the form in Database Manager. It will open straightaway in form view without your having to go into the corresponding table first.

Tutorial 8 — Listing your phonebook alphabetically

You now have the bare structure of a database and have entered some data. However, there are a number of ways of customizing the database to suit your needs. For instance, you may have noticed that the records in your database are in the order in which you entered them.

You can sort the records in your database by using Sort Orders which you apply to the contents of one or more fields. We’re going to explore the possibility of viewing the records in an order determined alphabetically by surname.

Sorting on a single field

To do a quick sort on a single field, follow these steps:

1. Go into Table Grid View and select the “Surname” field by clicking on the column bar above it.
2. Next, right-click your mouse and select Sort Ascending. The records will be sorted alphabetically by surname.

Sorting using a sort order

A Sort Order is slightly more advanced and allows you to sort on several fields at once. The sort order can also be saved and re-applied at will. We’re going to use it so that if two or more people in our phonebook share the same surname then they are sorted alphabetically by first name i.e. it makes sense to have Jim Smith before Terry Smith.

To create a sort order for a table, first go into the table and then follow these steps:

1. Click on the Sort Order button [a] on the Query toolbar. The “Format Query” dialog is opened at the Sort Order page. All the fields of the table are initially listed in the Available Fields box. You need to select the fields you wish to sort on - and in the right order - to determine the priority for each of the sort fields.
2. Select “Last name” by clicking on it and then click on Add. The field will be moved to the Selected Fields box.
3. Select “First name” and again click on Add to position it after the first field.
4. Give the sort order a name in the Name box, call it “List by surname” and click on OK. You will be asked if you want to create a new sort order. The dialog box should look like this:
Click **Yes** to save the sort order under the name you have given it.

You are returned to the Table Grid View with the sort order applied. The name of the sort order is displayed in the **Sort Order** box on the **Query** toolbar. Whenever you need to apply this sort order in future, just click on the arrow in the **Sort Order** box and select the sort order from the drop-down list. Alternatively you can open the table with the sort order already applied, by double-clicking on “List by surname” under **SortOrders** in the **Database Manager**.

For more details, select Database help from the Help menu and type **Sorting a table** into the index.

**Tutorial 9 — Customizing your phonebook for the office**

Once your phone book grows you may decide that while you’re at work you only need to see the records for your business contacts. This is easy to do using a filter. Filtering is a way of selecting records from a database table, according to values that you specify for certain fields. In this case we want to filter out any records in which the “Category” field is set to “Personal”.

**Filtering a table**

The filter can be either a simple filter on a single field or a complex filter on several fields at once.

In addition, you can fine-tune a named filter to apply *conditions* before selecting the records. Since any filter applied to a table is undone when the table is closed, a filter can be saved for re-use in later sessions. When you save a filter you need to give it a name so that you can re-apply it whenever you choose.

**Filtering on a single field**

To do a quick filter on a single field, follow these steps:

1. Go into Table Grid View.
2. Right-click in the “category” field column on any cell that contains “Business”. Select **Filter Using Selection** from the drop-down menu, followed by **= Equals**. This tells Ability to select only the records that contain this value in this column, that is, all the records that belong to your business contacts.
The table will be redrawn to show only those records allowed by the filter.

**Filtering using a named filter**

A named Filter allows you to filter the records according to the values in several fields at once. Generally, if you’re filtering on a single field then the previous method is preferable. However, the advantage for our purposes is that named filters can be saved and re-applied whenever you like.

To create a named filter for a table, first go into the table and then follow these steps:

1. Right-click over a "Business" entry in the Category column and select **Filter Using Selection**, followed by **Equals**.
2. Right-click over a blank telephone entry (if there are any) in the Work Number column and select **Filter Excluding Selection**.
3. Click on the **Filter** button and enter “Business only” in the **Name** box.
4. Click on **OK** to apply the filter. You will be asked if you want to create a new filter. Select **Yes** to save this filter for future use.

When you next want to apply the filter, just click on the arrow in the **Filter** box and select “Business only” from the drop-down list. Alternatively, in the Database Manager you can open your business phonebook immediately by double-clicking on “Business only” listed under Filters under the “Full Phonebook” table.

For more details on complex filters, select Database help from the Help menu and look up *Filtering using a named filter* in the index.

**Hiding fields from the table using a columns selection**

You don’t need to display every field in a database table. For instance, if we wanted to review only our business contacts then we wouldn’t need to see the home phone numbers (since we invariably don’t know them anyway) and we wouldn’t need to see the category (because we are only going to view business people anyway).

Open our table “Full Phonebook” from the Database Manager and then carry out the following:

1. Select the “home number” column.
2. Right-click and select **Hide**.
3. Select the “category” column.
4. Right-click and select **Hide**.
5. Click on the **Columns** button in the **Query** toolbar and then enter “Business only” in the **Name** box.
6. Click on the **OK** button.

**Note**: In future this columns selection is available directly from both the **Database Manager** and the columns selection drop-down list.

For more details, select Database help from the Help menu and look up *Hiding and showing columns in a database table* in the index.
Now we’re going to bring the various elements of our business-only phonebook together, using a very powerful technique known as **querying**. In Ability a full query is defined by selecting some columns from a table, applying a sort order, and choosing a filter condition. Queries are useful in that they allow you to apply their components all in one go, rather than having to individually apply each one. The outcome of a query is a table in its own right.

**Creating and applying a query**

The following steps show you how to create a query and then apply it to a table:

1. Go into *Database Manager*.
2. Right-click your mouse and select **New** and then **Query**. The "Format Query" dialog is opened. This is where you design the new query.
3. In the **Based On** box, click on **Table** and then click on the arrow in the box just to the right. The drop-down list displays all the tables in the current database. Click on "Full Phonebook" to select it. This is the table that the query will be based on.
4. Next, you need to select the query components that you will apply to the table. Click in **Columns** and select “Business only”, click in **Sort Order** and select “List by surname”, and click in **Filter** and select “Business only”.
5. Finally, give the query a name in **Query Name** at the top of the dialog – “Business phonebook”, say – and then click on **OK**.

The query will be applied to your table and a **Query table** opened up. This is based on the original table, with the component conditions of the query applied. The **Query** toolbar displays the query components as selected.

In *Database Manager* the new query will appear under **Queries**. Double-click here to select the query directly, without having to open the original table first.

For more details, select Database help from the Help menu and type **Queries** into the index.

**Creating a new form from scratch**

Now we’re going to create a new form in order to view our query, only this time we will build it from scratch rather than using an auto form. Follow these steps:

1. Go to *Database Manager* and right-click your mouse.
2. Select **New** and then **Form** from the displayed menu. A "Create Form Wizard" dialog is displayed.
3. On the first page of the dialog choose the layout of the form in the **Types** box: choose **Fields arranged across form** and then click on **Next** to go to the following page. (The Preview box shows you the difference between the two options.)
4. On this page choose the type of object you want the form to be based on: select **Query** to display the list of queries and then click on “Business only” query in the **Choose a database object** box. Click on **Next**.
5. On this page you choose which fields in the query you want to appear in the form. Select each of the three fields from the **Available Fields** box and click on the **Add** button, once for each one, to move them to the **Selected Fields** box.

6. Click on **Finish**.

A new form is created and displayed in design mode, giving you the opportunity to customize the layout, as we did earlier. Once you are finished, select **Save Form** from the **File** menu, call it “Business phonebook”, and click on **OK**.

In future you can double-click on this form in **Database Manager** and open your business-only phonebook straightaway.

**Tutorial 12 – Relations and reports**

Two important features of Ability Database that you can read up on in the Database Help are Relations and Reports.

Relations are tables that combine information from two separate tables.

Reports enable you to present your data in a more attractive and effective way.

For more details, select Database Help and search for *Relations* and *Reports* in the index.
**Ability Photopaint**

Photopaint is an image editing and creation program that allows you to enhance, create and experiment with all sorts of images, whether you want to remove blemishes from your photographs, create original designs from scratch, or combine various images into the one image. To this end Photopaint provides all the tools you will need for getting the best out of your images, both for fun and work.

The following tutorial will show you how to open an image, select an area to be edited, apply brush strokes, fill patterns or filters, layer your images, and make use of vector drawing tools. Although the image you will practice on won’t be the same as the one displayed in the tutorial, the principles you will learn are the same. Of course a tutorial can show you only a few of the basic operations, so you should refer to the online Help (access this through Help/Photopaint Help) to read about the full range of Photopaint features.

**Photopaint Tutorials**

The following tutorials are designed to take you through the most basic tasks you will need to use Photopaint successfully.

Before starting the tutorials you should read the section **Getting Help** and acquaint yourself with Photopaint’s on-line help facility. Any questions you have that aren’t answered by this booklet will almost certainly be answered there.

**Tutorial 1 – Opening an image**

Here we will go through the procedure for opening an image you have already saved, perhaps originating from a scanned photograph.

First open Photopaint:

1. Select the Start button on the Windows task bar
2. Select Programs and then Ability Office
3. Select Ability Photopaint

Open an existing image by selecting File/Open and locating the image in the “Open” dialog.

Once the image file has opened several essential dialog boxes will be automatically displayed. Close these down for now (you can open any of them later on with a couple of clicks).

Since the image file will appear in the Photopaint window as a file of the type in which it was originally saved, select File/Save As to convert it into a Photopaint file (extension apx). This should already be in the Save as type line; if it isn’t, just click on the arrow and select the right type from the list.

It is likely that the image will initially be too large for the window. Reduce it by selecting View/Fit on Screen.

You can now get to work on the image, using the Tools bar on the left of the screen (if this isn’t visible, select View/Tools).

The Tools bar contains many of the tools you will need while working with an image, so it should always be displayed.
Tutorial 2 – Selections

Selections allow you to restrict the area that can be worked on in an image, allowing you to concentrate your work while also protecting the rest of the image from unwanted changes.

Photopaint provides a variety of selection tools, all gathered together at the top of the Tools bar. Once a selection is made you can edit the image only within the selection borders, although you can change these borders at any time.

The selection options are: Rectangular, Lasso, Single Row, Single Column, Ellipse, Magic Wand, Polyline Lasso and B-Spline. Here we’ll take a look at a couple of the options and show how a selection can be edited – or transformed – to help you fine tune the area you want to work on.

We’ll apply an Elliptic selection:

1. Click on Elliptic Selection on the Tools bar.
2. Drag the mouse pointer over an area of the image and release.
3. The elliptic selection is displayed as an ellipse with a moving, dotted border.

You can now change the shape of the ellipse (or any other selection) like this:

1. Click on the Transform Selection button on the Tools bar. A box with handles is placed round the selection to indicate that it can now be edited, or transformed.
2. Drag one of the handles to a new position. The ellipse selection will expand (or contract) into the new selection boundary.
3. Move the mouse pointer outside the transform box and when it turns to a curved double-headed arrow, rotate the selection by dragging your mouse. Note that the symbol in the middle of the selection acts as the center of rotation. Drag it to a new position to create a new center of rotation.
4. Move the whole of the selection by placing the mouse pointer within the selection and dragging it to a new position.

These are the transforms you can perform with your mouse, and are called Free Transforms.

There are many more selection transforms, available by right-clicking to display a pop-up menu. The transforms here are more versatile and can be applied only one at a time:

<table>
<thead>
<tr>
<th>Free Transform</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scale</td>
</tr>
<tr>
<td>● Rotate</td>
</tr>
<tr>
<td>Skew</td>
</tr>
<tr>
<td>Distort</td>
</tr>
<tr>
<td>Perspective</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Numeric...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate 180°</td>
</tr>
<tr>
<td>Rotate 90° CW</td>
</tr>
<tr>
<td>Rotate 90° CCW</td>
</tr>
</tbody>
</table>

| Flip Horizontal|
| Flip Vertical  |

Here are a couple of the options:
1. Select **Flip Vertical**. The selection “flips” around an imaginary vertical axis.

2. Select **Skew**. Skew the transform box by dragging a handle in the direction of the line on which it is situated. You can drag the handle in only one direction at a time. The selection will adjust to fit the skewed box.

Read about the full range of selection editing options in the Help files – type Transform options in the index line.

You can cancel a selection at any time by selecting **None** from the Select menu. You first have to make sure, though, that the selection is not in transform mode: click on any other tool on the Tools bar to cancel the transform mode, though the original selection will still be applied until you cancel it.

**Transform Image**

In addition to transforming a selection, you can also transform an image, that is, use a selection to move, stretch, rotate or change in some other way a selected part of the image.

Transform Image works in a similar manner to Transform Selection. After you have made the selection using one of the standard selection tools bar, click on the Transform Image button on the Tools bar. You can now use any of the Free Transforms or right-click for the full set of options. Once the selection is transformed, the image within the selection will change too i.e. move, stretch, rotate, etc.

**Using zoom**

If the area you want to work on is small you will probably want to magnify it. You can make a selection either before or after applying magnification, and then of course use the selection transform tools as you wish.

1. Click on **Zoom** on the Tools bar. The pointer turns to a magnifying glass.

2. Drag the pointer round the area you want to magnify and release the mouse. If you have already made a selection, drag it round the selection. Note that the area you have covered with the Zoom tool is expanded to fit the Photopaint window, hence the smaller the zoom area the greater will be the magnification applied to the image as a whole.

3. Once you have applied Zoom, you can use the **Hand** tool to move around the image. Alternatively use the vertical and horizontal scroll bars.

4. If you would like to change the magnification, right-click and select from **Zoom In** (increases magnification), **Zoom Out** (decreases magnification), **Actual Pixels** (reduces image to original size) and **Fit To Screen** (fits image to screen. The maximum magnification is 1600%, or 16 times the original size).

5. You can now go ahead and edit the image, for example by applying brushstrokes or a color fill.

**Tutorial 3 – Applying brushstrokes**

We will now apply some brushstrokes to the selection.

Click on **Paintbrush** on the Tools bar.

In the “Brushes” dialog, select one of the brushes.
Note that the brushes come in a variety of size, shapes and textures. You can also design your own brushes (see *Brushes* in the *Photopaint Help*).

Choose a color for the brush by clicking on the top **Color Selector** at the bottom of the **Tools** bar and selecting a color in the “Select Color” dialog box. Note that the two selectors can be swapped round by clicking on the arrows beneath them. The brushes use the color of the current top selector.

Drag the mouse pointer across the selected area to apply the color. Note that if you do stray outside the selection the brushstroke has no effect.

Select **Edit/Undo Brush Stroke** to clear the applied color.

We will now look at how the brushes combine with opacity and mode to create certain effects. (Note that what is said here is true of all the tools that apply color: *Paintbrush*, *Pencil*, *Duplicate*, *Fill* and *Gradient Fill*.)

Basically, the brush modes determine how an applied brush stroke interacts with the colors already in an image. Each one has a different effect and the effect is modified in each case by the degree of opacity/transparency you set. For instance, if you paint a blue line over a patch of red in an image, you may want the red to be completely replaced by the blue, or the two colors blended in some other way. The brush modes allow you to decide how and to what extent the applied color will affect what is already there.

The default brush mode is **Normal**. The brush color is applied in full, that is to say, the existing base color is totally over-painted when the **Opacity** is set at 100%. The lower you set the opacity the more see-through the applied brush stroke color becomes, that is, the base color shows through. At an opacity of 0, the brush stroke color is totally replaced by the base color.

**Dissolve**. A color applied with a less than 100% opaque brush is converted - “dissolved” - to 100% opaque randomly scattered pixels. This means that the brush color is applied in “solid” scattered pixels throughout the base color. The lower the opacity the fewer the brush color pixels and the more the base color dominates. Dissolve is useful when you want to have the effect of a rough brushstroke, rather like a crayon mark.

There are many other modes, although note that you usually need to reduce Opacity below 100% for their effects to be visible. Go ahead and experiment with these and with the different brushes themselves.
Tutorial 4 – Fill

We’ll now entirely fill the selection with a color.

This tool allows you to apply color by clicking on an image. The color you click on will be taken as the standard, and all adjacent pixels within a certain tolerance, using either the default or one set by you, will be filled in with the Fill color. The tolerance is a measure of the brightness of pixels and stretches out in either direction from the selected color. The Fill color itself is the currently selected foreground color (to choose another color click on the higher Color Selector to open up the “Select Color” dialog).

Click on **Fill** on the **Tools** bar.

In the “Fill Options” dialog set the following options:

1. Select the mode in the **Mode** box and the opacity in **Opacity** (as with brushes, the mode and opacity determine how the fill color will interact with the existing colors in the image). The default is Normal.
2. The tolerance is set in the Threshold box: 0 causes only adjacent pixels with exactly the same color to be filled; 255 causes all pixels in the image to be filled.
3. Leave **Color Fill** checked to apply a color fill. (Search **Photopaint Help** for details on Pattern Fill.)
4. Once you have chosen a suitable color and set the threshold, opacity and mode, just place the Bucket pointer over the area to be filled and click once. The fill will go ahead according to the settings you chose.

Tutorial 5 – Filters

Filters are the Photopaint equivalents of the filters used in photography to create various effects. As in photography, some filters are merely corrective in that they try to preserve the appearance of the original image while removing some defects, and others are creative in that they radically change the image.

You can experiment with the great variety of filters in Photopaint, but also download “plug-in” filters from the internet.

Here we will show you how to use one filter and let you experiment with the rest yourself.

First, note that all the filters are accessible through the **Filters** menu and are grouped into several general categories, for example, Artistic, Sharpen, Distort, Tiles, and others. Within these categories there is a wide range of filters, many of which are editable by you.

Take a look at **Super Nova** under **Light Effects** in the **Filters** menu.

In the “Super Nova” dialog, it is possible to edit and preview the filter before applying it. This makes it easy for you to play around with the filter before applying it to the image itself.
1. Use the **Radius** slider to increase or decrease the length of the spokes that spread out from the super nova.

2. Use the **Spokes** slider to increase or decrease the number of spokes of the super nova.

3. You can immediately see the effects in the **Preview** box to the left.

4. X and Y (measuring X across and Y down from the top left-hand corner) give the horizontal and vertical positions respectively. It is better to set the position by eye by clicking the mouse pointer – the “hand” – at the spot in the Preview image that you want to be the center of the super nova. Alternatively set precise values by typing them in the **X/Y** boxes. Note that the maximum values of X and Y are the horizontal and vertical dimensions of the image measured in pixels.

5. The current color for the filter is shown in the **Color** box at the bottom of the dialog. You can change this by clicking on the box and selecting a new color in the “Select Color” dialog.

6. Once you have designed your super nova, click on OK and watch the filter take effect. Depending on the size of the image, it can take anything from a few seconds to a couple of minutes.

Note that if you have previously set a selection the filter will be applied only within the selection borders. Also, you can continue to apply filters to the same image. Try **Page Curl**, for instance, on top of **Super Nova**.

### Tutorial 6 – Layers

Layers are an essential feature of Photopaint. With them you can treat an image as a series of separate superimposed images, each occupying its own transparent layer. This transparency enables you to see through the transparent areas on one layer to the image on the layer below.

The obvious advantage of this is that you can create or edit an image on one layer without disturbing images on other layers. Since you can also adjust the transparency and blend mode of each layer, and change the order of the layers, the task of combining component images is made both easier and more sophisticated.

#### Using layers

We will open an image on one layer, create a second and third layer, and apply filters to both the higher layers to compare their effect on the image. We will then choose one of the filter effects and combine it with the image layer to create a new image. During the course of this we will go through some of the other layer options.

First, open an image file.

If the “Layers” dialog isn’t open, select it in the **View** menu.
Note that if the image is a pre-existing image file, the bottom layer will be called Background rather than Layer 1. Since it is best to keep the original file clean, it is a good idea to make a duplicate of the file by selecting Duplicate from the Image menu. After the duplicate file is created, go to the Windows menu and select the original file, and then close it. The duplicate file will still be open and will be called Copy of [name of original file]. Save this and rename it if you wish. Note that it will be saved as a Photopaint file (with apx extension). (See Help for notes on background layers and duplicates.)

The Background layer (in effect, Layer 1) can now be used as the basis for your work.

Create a second layer – Layer 2 – by clicking on New Layer in the dialog.

In the “New Layer” dialog, click on OK to create Layer 2.

There are now 2 layers visible in the dialog.

Make a layer the current one by selecting it. Here we will select the top layer. The currently selected (or highlighted) layer is the active layer. Any editing you do is always implemented on the active layer. Since it is not possible to have more than one active layer at a time, none of the inactive layers will be affected by your editing. This is, of course, the main value of layers in the first place. You can make any other layer the active one simply by clicking on it.

The Eye symbol indicates whether a layer is currently visible (to make the layer invisible, click the Eye off). By switching off a layer you make it impossible to see any image content from that layer, thereby making the content of the layer below visible (in so far as it was hidden by the image on the hidden layer). You can switch off as many layers as you like, and also have any combination of switched-on and switched-off layers.

With Layer 2 selected, select a filter from the Filter menu, say, a white Super Nova applied to the top right hand corner. In the dialog this is shown on Layer 2.

Create another layer, Layer 3. Select this layer. This time we'll add a piece of text. Click on the Type tool button on the Tools bar. In the “Type Tool” dialog, type in some text, say, Home Sweet Home, click on the Font button to set a color and font size, and then click on OK. The text is displayed on Layer 3.

There are now two additions to your image, applied on two separate layers, with the bottom background layer remaining untouched.

Experiment with the two layers by alternately switching the respective Eyes on and off.

You can make the filter effects fainter by using the Opacity slider in the dialog. In combination with this you can apply different blend modes from the Mode box. These work in a similar way to the opacity and blend mode you experimented with when applying brushstrokes, but with the one essential
difference: they are applied to the whole of the layer and can be changed edited by merely altering the opacity and blend mode once again. To alter the opacity or blend mode of a layer, first select the layer.

To change the order of the layers use the Up, Down, First and Last buttons. These always work on the currently selected layer and act just as their names suggest, moving the selected layer up one, down one, to the top or bottom of the stack of layers.

Once you are satisfied with the image (that is, once you have chosen, with the help of the Eye, an order for the layers, the degree of transparency/opacity of each of the layers, and which of the filters you’d like to apply), you can merge the required layers into one by selecting Flatten Image from the Layers menu.
Integration within Ability Office

Integration is a term used to describe how different applications work together and especially how they share data.

There are three main ways in which Ability can share information:

1. Copy and paste.
2. Linking through fields.
3. Embedding and linking documents.

Copy and paste

In the previous tutorials we’ve discussed using the Copy and Paste buttons to transfer data from one part of a document to another. This technique can also be used to move data between applications.

Database and Spreadsheet both use rows and columns to order data, so when you copy data from one application to another this structure is preserved. Write also uses rows and columns, but here a row is represented by a paragraph and a column by a tab stop. So, for instance, if you were copying a selection of rows and columns from Spreadsheet and pasting it into a Write document, each column would appear separated by a tab stop and each row would begin on a new line. Conversely, when you paste from Write into Spreadsheet, tabs will begin new columns and paragraphs new rows.

For more details, select User’s Guide from the Help menu and type Copy and Paste into the index.

Linking through fields

Wherever you are working in Ability, whether in Write, Spreadsheet or Database, you will often find it useful to insert fields. Various types of field are available, including date and time, page number, formula, mail merge, database lookup, and linking.

One of the most powerful features of Ability is the capacity for a field in one document or application to refer to a field in any other Ability document or application. Such a relationship is called linking and can take two forms:

1. A one-way link is used to access data that is located in another document, from the current document. The data can be displayed or used in a formula, but cannot be changed unless you open the original document.
2. A two-way link allows you to change data at either end of the link. This means that the original document is updateable from the target document.

Mail Merges

One of the easiest examples of linking fields is a mail merge, whereby names and addresses from a database can be inserted into a letter template in Write. This enables you to quickly create a number of letters that are identical in everything but the details of the recipients. To do this you would do as follows:

1. Open your Write document.
2. Select Mail Merge Field from the Insert menu to display the "Insert Mail Merge Field" dialog.
3. Enter the name of your Database file in the File Name box (or use the Browse button to locate it).

4. From the Data Source drop-down box, choose from the list of tables from the selected database.

5. From the Data Item drop-down box, choose from the list of fields from the selected table.

6. Finally, click on the OK button. The field will appear on the page, with the first item of data from the first record in the database already displayed.

7. You'll probably want to add some more fields, especially if it's a whole address you want to display. At this point you can easily insert extra fields from the same table without having to open the dialog again. Position the cursor where you want the next field to go and then click on the arrow in the box to the left of the Insert Field button. Select the required field from the drop-down list and then click on the button to insert it.

8. Repeat this process till all the required fields are inserted.

9. Use the Next, Previous, First and Last buttons to move through the records as you wish, with the details changing, as you would expect, for each record.

For more details, select User’s Guide from the Help menu and type Mail Merge into the index. Also, take a look at Linking through fields.

Embedding and linking documents

It is possible with Ability to insert a chart or part of a spreadsheet into a report you are creating in Write, and to have the Write document update automatically should the original spreadsheet change. You can also insert Draw documents or picture files into either Write or Database Documents. This technique is called Object Linking and Embedding (or OLE for short) and is supported by all the Ability applications to some extent.

For more details, select User’s Guide from the Help menu and type Linking and embedding into the index.